CentOS 5.x 系统下使用yum 升级php到5.2.x 最方便方法

WordPress需要PHP的版本5.2x以上,如果你的PHP是yum安装的,很有可能PHP的版本是5.1x,通过以下方法升级PHP到5.2比较方便,现推荐给大家。

  1. # rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
  2. # vi /etc/yum.repos.d/CentOS-Base.repo

增加下面信息

  1. [utterramblings]
  2. name=Jason's Utter Ramblings Repo
  3. baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
  4. enabled=1
  5. gpgcheck=1
  6. gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

执行命令,自动升级。

  1. yum update php -y
  2. yum install libmcrypt -y
标签:PHPCentosYum 发布于:2019-10-06 00:52:04